Open navigation

Collaborate Ultra - System Requirements

  • INTO Glasgow Caledonian University
  • INTO University of East Anglia

Collaborate Ultra requires a modern web browser with WebRTC support. Please check the Collaborate Ultra Supported Browsers to make sure you use a supported browser.

Collaborate requires certain permissions to function as desired. For example, Collaborate needs permission to access your camera and microphone so you can use audio and video. Give Collaborate permission when asked, and/or set up permissions in browser preferences.

Collaborate doesn't require or use plugins. All you need is one of the supported browsers.

If you have problems then please check the Collaborate Ultra Help for Participants or the Collaborate Ultra Troubleshooting guide.


Was this answer helpful? Yes No

Sorry we couldn't be helpful. Help us improve this article with your feedback.